Графики
Как известно, графики являются одним из основных способов визуального представления числовых данных и проведения технического анализа. Для представления данных программа Альфа-Директ позволяет использовать три основных типа графиков и их комбинации.
  • Линейный график (Open, High, Low, Close) - отражает изменение цены финансового инструмента от времени. Это - достаточно наглядный тип графиков, однако он не дает полной картины динамики рынка, и должен использоваться вместе с другими типами графиков. Линейный график строится по выбранному потоку данных - Open (цена открытия каждого временного периода), High (максимальная цена каждого временного периода), Low (минимальная цена каждого временного периода), или Close (цена закрытия, последняя цена каждого временного периода). Временной период устанавливается в настройках графика.
  • Гистограммы - отражает изменение количества проданных ценных бумаг по времени. Этот тип графика полезен в сочетании с другими типами графиков, например с линейным графиком цены. Также гистограммы используются для отображения некоторых индикаторов для технического анализа.
  • Свечи (Candle) - один из самых наглядных и часто используемых типов графиков. Хотя этот тип графика часто используется для представления динамики рынка на ежедневных графиках, его также можно с успехом применять и для более коротких временных периодов. В зависимости от цвета различают белые (бычьи) и черные (медвежьи) свечи. Если цена при закрытии торговой сессии была выше, чем при открытии, то в таком случае используется белая свеча. В противном случае используется черная свеча. Форма свечи состоит из следующих элементов:
    • Тело свечи - прямоугольник, верхней и нижней границами которого являются соответственно: цена закрытия и цена открытия для белых (бычьих) свечей и цена открытия и цена закрытия для черных (медвежьих) свечей.
    • Тени - вертикальные штрихи, выходящие сверху и снизу из тела свечи, и отображающие соответственно максимальную и минимальную цену за торговую сессию.
    Внимание! Для лучшего визуального восприятия на графиках в программе Альфа-Директ по умолчанию используется зеленый цвет для белых свечей и красный для черных (см. приведенный ниже рисунок). При желании вы можете изменить эти цвета на другие (см. раздел "Настройка графика").
    На приведенном ниже рисунке показан пример реального графика "Свечи (Candle)" в программе Альфа-Директ.

    Построение графика
    В программе Альфа-Директ существует два способа построения графика - из контекстного меню в окнах котировок и с помощью мастера графиков. У обоих способов есть свои преимущества - первый способ требует меньше времени для построения графика, зато второй способ является более универсальным и, в отличие от первого, позволяет сразу получить график требуемой периодичности за требуемый период.
    Чтобы построить график из контекстного меню в окне котировок
    В окне Котировки щелкните правой кнопкой мыши строку, соответствующую нужному финансовому инструменту, а затем выберите команду Построить график в контекстном меню. Появится новое окно, содержащее график цены соответствующего инструмента. Параметры графика зависят от текущего стиля (см. Стили). При необходимости параметры и настройки этого окна можно изменить, воспользовавшись соответствующими пунктами контекстного меню.
    Чтобы построить график с помощью мастера графиков
    1. Выберите команду Графики в меню Информация или нажмите кнопку    "Мастер графиков" на панели инструментов;
    2. Появится диалоговое окно Инструменты для выбора инструмента;
    3. Для упрощения поиска нужного инструмента воспользуйтесь фильтром по наименованию Выпуска (можно указать часть названия, например, ЕЭС, или тикер - обозначение инструмента в Альфа-Директ, например, EESR) и\или Списка;
    4. Выделите инструмент на нужном рынке;
    5. Нажмите кнопку ОК;
    6. В появившемся окне Свойства графиков при необходимости измените визуальные и функциональные настройки графика;
    7. Нажмите кнопку ОК;
    8. Появится новое окно, содержащее график выбранного инструмента с указанными параметрами;
    9. При необходимости можно изменить параметры и настройки этого окна, воспользовавшись соответствующими пунктами контекстного меню.
    Чтобы добавить (удалить, изменить) инструмент в окне графика
    Программа Альфа-Директ позволяет добавлять графики других инструментов в существующую или новую область окна графика. Также можно изменить инструмент или удалить его график из окна. Чтобы добавить (удалить, изменить инструмент) график еще одного инструмента в уже имеющемся окне, выполните следующие действия.
    1. Щелкните имеющийся график правой кнопкой мыши, а затем в появившемся контекстном меню выберите команду Графики. Появится диалоговое окно Свойства графиков с открытой вкладкой Инструменты;
    2. Для добавления графика другого инструмента нажмите кнопку Добавить, выберите нужный инструмент из списка и при необходимости измените для него визуальные параметры (вид), а также область отображения и ось;
    3. Для удаления графика инструмента выберите соответствующий график в списке и нажмите кнопку Удалить;
    4. Для изменения инструмента выберите в списке соответствующий график и нажмите кнопку Изменить, затем выберите нужный инструмент из списка и при необходимости измените для него визуальные параметры (вид), а также область отображения и ось;
    5. Нажмите кнопку Ок;
    Чтобы добавить (удалить) индикатор в окне графика
    Как известно, использование индикаторов позволяет получить более полную картину динамики рынка. Программа Альфа-Директ позволять и удалять индикаторы в существующую или новую область окна графика. Чтобы добавить или удалить график индикатора в имеющемся окне графика, выполните следующие действия.
    1. Щелкните имеющийся график правой кнопкой мыши, а затем в появившемся контекстном меню выберите команду Индикаторы. Появится диалоговое окно Свойства графиков с открытой вкладкой Индикаторы;
    2. Для добавления нового индикатора найдите и выделите нужный индикатор в списке доступных и нажмите кнопку Добавить. При необходимости измените параметры индикатора, визуальные параметры (вид), а также область отображения и ось;
    3. Для удаления индикатора выберите соответствующий индикатор в списке и нажмите кнопку Удалить;
    4. Нажмите кнопку Ок;

    Контекстное меню окна графика
    Щелкните график правой кнопкой мыши, а затем в появившемся контекстном меню выберите нужные команды.
    • Купить-продать ц.б. - Вызов диалогового окна подачи заявки (быстрый вызов F2);
    • Курсор - открыть\закрыть окно курсора
    • Настройка - вызов диалогового окна настройки всех параметров графика
    • Графики - добавление\удаление графиков инструментов из текущего окна, изменение цвета, стиля и внутреннего окна для отображения, а также выбор соответствующих осей
    • Индикаторы - добавление, удаление и изменение параметров индикаторов
    • Уровни - включение\выключение отображения линий уровня поддержки и сопротивления
    • Тренд - рисование линий на графике. Для изменения параметров или удаления существующих линий тренда в окне Настройка откройте вкладку Тренды или дважды щелкните левой кнопкой мыши по нужной линии тренда;
    • Обновить - запрос обновления информации по всем инструментам во всех областях текущего окна графика за указанный период;
    • Масштаб - изменение периода, периодичности и интервала графиков в текущем окне
    • Экспорт в файл - вызов вкладки Данные окна Настройки графиков для сохранения данных для графиков в текстовом формате.
    • Печать - печать содержимого всех областей выбранного окна графика с предварительной настройкой параметров печати
    • Закрыть окно - закрыть текущее окно
    Совет. Чтобы увеличить масштаб какого-либо участка графика, нажмите кнопку    (включить увеличение) в правом нижнем углу окна графика, поместите указатель мыши на одной границе предполагаемого участка, нажмите левую кнопку мыши и, не отпуская ее, перемещайте указатель до другой границы участка. Отпустите кнопку, и выделенный участок будет увеличен до размера окна графика. Чтобы вернуться к обычному масштабу, нажмите кнопку    (выровнять) в правом нижнем углу окна.

    Настройка графика
    В окне Свойства графиков можно изменить различные свойства и параметры элементов окна Графики - окна, осей, инструментов, индикаторов, уровней и трендов, а также просмотреть и при необходимости экспортировать в файл числовые данные для соответствующего графика.

    Окно
    Вкладка Окно окна Свойства Графиков позволяет настроить визуальные параметры для области отображения, такие как Фон окна, Цвет границы, параметры шрифта для осей и подписей названий инструментов (Легенды), параметры отображения Заголовка окна и Легенды, а также Автономного режима окна и Прозрачности. Изменение режима прозрачности возможно только после включения и применения свойства Автономный режим окна.
    Здесь же можно сохранить текущие настройки для окна Графиков в Стиль или выбрать один из ранее сохраненных Стилей для применения к текущему окну соответствующих настроек.

    Ось времени
    Настройка параметров Осей времени включает указание периода отображения, периодичности, видимой области, визуальные настройки для основной (время) и дополнительной (даты) шкал.
    График строится либо за указанное количество дней, либо начиная с указанной даты Начало периода, до текущего дня либо до указанной даты Окончание периода.
    Для периодичности Intraday (внутридневной) необходимо дополнительно выбрать Тип графика - от 1 минуты до 1 часа.
    Совет: для отображения графика за длительный период используйте периодичность 1 час или Daily (дневные), Weekly (недельные) или Monthly (месячные). Использование 1-минутных графиков для отображения данных более чем за 1 месяц может привести к замедлению работы терминала из-за недостатка ресурсов компьютера.
    Совет: для графиков периодичности Daily, Weekly или Monthly рекомендуется отключить отображение Основной шкалы (времени) для освобождения дополнительной свободного места в области отображения графиков.

    Инструменты
    Для добавления нового инструмента в существующее окно графика, изменения или удаления имеющихся инструментов, а также настройки визуальных параметров и параметров отображения (выбор области и оси) для соответствующих графиков щелкните правой кнопкой мыши в области данных окна графиков и выберите пункт Графики или откройте вкладку Инструменты окна Свойства графиков.
    Для добавления нового графика в существующее окно графиков нажмите кнопку Добавить, выберите из списка нужный инструмент (для поиска можно пользоваться фильтром - как по названию, так и по тикеру и\или списку) и нажмите Ок. Выбранный инструмент появится в списке, при необходимости для него можно изменить параметры отображения. Для графиков типа Candle (Свеча) или Bar (столбики) можно указать цвета возрастания и убывания, а для линейных графиков по ценам открытия (Open), Максимума (Max), Минимума (Min) или Закрытия (Close) каждого временного интервала для выбранной периодичности и типа графика, указывается цвет и тип линии.
    При добавлении нового графика в существующее окно автоматически создается новая (пустая) область с одной осью данных. При желании построить новый график в существующей области, нужно выбрать соответствующую область из списка и одну из осей этой области для отображения.
    Области, в которых нет ни одного графика, удаляются автоматически. Оси, которые не относятся ни к одному графику, также удаляются автоматически.
    Совет: для построения графиков разных инструментов не рекомендуется использовать для отображения одну и ту же ось, кроме случаев, когда цены инструментов близки по значению, либо используется сравнительная (процентная) ось.
    Для изменения инструмента выделите соответствующий инструмент в списке и нажмите кнопку Изменить, выберите из списка нужный инструмент (для поиска можно пользоваться фильтром - как по названию, так и по тикеру и\или списку) и нажмите Ок. Новый инструмент займет в списке место старого, при необходимости для него можно изменить параметры отображения.
    Для удаления инструмента выделите соответствующий инструмент в списке и нажмите кнопку Удалить.
    Для отображения на оси последнего значения цены инструмента включите соответствующую опцию.

    Индикаторы
    Для добавления нового индикатора в существующее окно графика, изменения или удаления имеющихся Индикаторов, а также настройки различных параметров щелкните правой кнопкой мыши в области данных окна графиков и выберите пункт Индикаторы или откройте вкладку Индикаторы окна Свойства графиков.
    Для добавления нового индикатора в существующее окно графиков выделите нужный индикатор в списке доступных и нажмите кнопку Добавить, выберите инструмент, область отображения и ось. При необходимости измените Параметры индикатора и настройте Вид (цвет, толщина линии).
    Для изменения параметров и свойств имеющихся индикаторов выделите соответствующий индикатор в списке построенных индикаторов и задайте для него нужные параметры.
    Совет: для построения сглаживающих и/или трендовых индикаторов, имеющих одинаковую размерность с графиков базового инструмента, рекомендуется использовать для отображения одну и ту же область и ось, а во всех остальных случаях - разные оси для отображения.
    Если для отображения индикатора выбрана сравнительная ось, соответствующий индикатор не отображается на графике.
    Для отображения на оси последнего значения индикатора включите соответствующую опцию.
    Для получения оповещения в виде всплывающего окна в терминале при пересечении графиков индикатора и инструмента, по которому этот индикатор построен, включите опцию    оповещать при пересечении графика Инструмента. Это оповещение работает только для тех инструментов и индикаторов, которые построены по одной общей оси.

    Ось значений
    Для добавления новой области отображения или оси значений в существующее окно графика и изменения имеющихся осей, а также настройки их различных параметров щелкните правой кнопкой мыши в области данных окна графиков и выберите пункт Настройка и/или откройте вкладку Ось значений окна Свойства графиков.
    Для добавления новой области в существующее окно графиков нажмите кнопку Новая область. В списке областей появится пустая область, содержащая одну новую ось.
    Добавление новой оси происходит аналогично.
    Названия для областей и осей присваивается автоматически по коду инструмента или индикатора, который (или которые) расположен в этой области или привязан к соответствующей оси.
    Добавленные, но неиспользованные области и оси удаляются автоматически при закрытии окна Свойства графиков.
    При необходимости для каждой оси можно изменить единицы измерения, точность, расположение (справа или слева), или сделать ось сравнительной (процентной). Также настраиваются параметры отображения сетки для каждой из осей
    Для изменения параметров и свойств имеющихся осей выделите нужную ось в соответствующем списке и задайте для нее нужные параметры.
    Совет: для построения нового графика в имеющейся области с новой осью сначала создайте эту новую ось в нужной области, а затем выберите ее в настройках свойств отображения для соответствующего графика.

    Уровни
    Для включения, настройки или отключения отображения уровней поддержки и сопротивления щелкните правой кнопкой мыши в области данных окна графиков и выберите пункт Уровни и/или откройте вкладку Уровни окна Свойства графиков.
    Для отображения на оси установленных значений уровней включите соответствующую опцию.
    Для получения оповещения в виде всплывающего окна в терминале при пересечении графика инструмента и линии уровня, включите опцию    оповещать при пересечении графика Инструмента.

    Тренды
    Для добавления новой линии тренда в окно графика щелкните правой кнопкой мыши в области данных окна графиков, выберите пункт Тренды, переместите указатель в точку предполагаемого начала тренда, нажмите левую кнопку мыши и, не отпуская ее, переместите указатель в место предполагаемого окончания линии тренда. Отпустите кнопку мыши, линия тренда добавлена. Или откройте вкладку Индикаторы окна Свойства графиков, выберите в списке инструмент, по оси которого будет построена новая линия тренда. Нажмите кнопку Добавить, укажите координаты точек начала и окончания тренда в системе координат (Время, Значение) и параметры его отображения, нажмите кнопку Применить или Ок. Для быстрого выбора значений по точкам локальных минимумов (для тренда поддержки) и локальных максимумов (для трендов сопротивления) используйте кнопки со стрелками рядом с соответствующими полями значений.
    Примечание: Линии тренда, построенные по сравнительной оси, не отображаются в окне.
    Для удаления имеющейся линии тренда откройте вкладку Индикаторы окна Свойства графиков, выделите нужный тренд в списке и нажмите кнопку Удалить.
    Для изменения параметров и свойств имеющихся линий тренда выделите соответствующий тренд в списке и задайте для него нужные параметры.
    Совет: Включите опцию    экстраполировать тренд до оси значений для автоматического продолжения линии тренда вправо по оси времени до последней точки на графике.
    Для отображения на оси последнего значения индикатора включите соответствующую опцию.
    Для получения оповещения в виде всплывающего окна в терминале при пересечении графиков индикатора и инструмента, по которому этот индикатор построен, включите опцию    оповещать при пересечении графика Инструмента.

    Данные
    Для просмотра числовой информации по графикам, построенным в окне, а также экспорта данных в текстовый файл, щелкните правой кнопкой мыши в области данных окна графиков и выберите пункт Настройка и/или откройте вкладку Данные окна Свойства графиков.
    Выберите нужный инструмент из списка, в таблице появятся соответствующие данные. Для перемещения по таблице используйте полосу прокрутки или навигационные кнопки первая запись, предыдущая запись, следующая запись, последняя запись.
    Для удаления записи из локальной базы нажмите кнопку удалить. Удаленные из локальной базы данные восстановятся при обновлении соответствующего временного периода с сервера.
    Для обновления таблицы из локальной базы нажмите кнопку обновить. При этом перечитываются данные из локальной базы пользователя, обращения к серверу Альфа-Директ не происходит.
    Совет: Для обновления данных с сервера щелкните правой кнопкой мыши в области данных окна графиков и выберите пункт Обновить.
    Для экспорта данных в текстовый файл нажмите кнопку Экспорт в файл и выберите имя файла для сохранения.

    Печать графика
    Чтобы напечатать график в основном или вспомогательном окне, щелкните область графика правой кнопкой мыши, а затем выберите команду Печать в контекстном меню. Появится стандартное диалоговое окно для выбора принтера и параметров печати

    Элементы технического анализа
    Технический анализ - это совокупность методов прогнозирования цены, основанных на изучении графиков динамики рынка за предыдущие периоды времени. Под динамикой рынка обычно понимают изменение цены и числа сделок. Чтобы получить наиболее полную картину состояния рынка, важно использовать оба эти индикатора. Программа Альфа-Директ позволяет использовать для анализа данных основные методы технического анализа, например, Простые скользящие средние (Moving Average), Экспоненциальные скользящие средние. (Moving Average Exp), Индекс относительной силы (RSI), линии тренда и многие другие индикаторы, построение которых аналогично описанным ниже, а описание следует искать в специальной литературе по техническому анализу
    Внимание! Перечисленные выше методы технического анализа следует применять к ранее построенным графикам. Примечание. Данное руководство не содержит описания теории технического анализа и интерпретации его методов.
     
    Скользящие средние
    В программе Альфа-Директ используется два типа скользящих средних:
    • Простые скользящие средние (Moving Average) - показывают среднее значение цены за определенный период и вычисляются по формуле
      MA = ( Pi)/n, где
      Pi - i-я цена (i меняется от 1 до n);
      n - порядок скользящей средней;
       

      Пример окна графика с двумя простыми скользящими средними - по последней цене инструмента и по количеству с одинаковым периодом = 30.

    •  
    • Экспоненциальные скользящие средние (Moving Average (Exponential)) - этот тип отличается от предыдущего тем, что каждой из цен рассматриваемого периода придается определенный "вес", который увеличивается по мере приближении к текущей цене. Для вычисления используется следующая формула
      EMAt = EMAt-1 + (k (Pt - EMAt-1)), где
      t - текущий момент (по умолчанию t = 3);
      Pt - t-я цена;
      k = 2/(n+1);

    Чтобы построить экспоненциальную скользящую среднюю
    1. Постройте для выбранного инструмента график, как описано в разделе "Построение графиков".
    2. Щелкните правой кнопкой мыши область графика и выберите команду Индикаторы
    3. В появившемся диалоговом окне Настройки, вкладка Индикаторы в списке доступных индикаторов выделите нужный (например, Moving Average (Exp)) и нажмите кнопку Добавить.
    4. Выберите из списка инструмент, по данным которого должен быть построен индикатор, область и ось для отображения. В нашем примере имеет смысл выбрать область и ось основного инструмента, чтобы индикатор Moving Average (Exp) отобразился в той же области и его значения отображались на оси инструмента.
    5. Укажите параметры индикатора, например, Цена=Закрытие, Период=60
    6. Измените (при необходимости) цвет и стиль линии индикатора
    7. Нажмите кнопку Применить

    Индекс относительной силы RSI
    Индекс относительной силы RSI (Relative Strength Index) является одним из самых популярных осцилляторных методов, используемых трейдерами. Он был разработан J. Welles Wilder в 1978 году.
    Вообще говоря, название "Индекс относительной силы" - несколько неверно, поскольку осциллятор RSI сравнивает силу не двух инструментов, а внутреннюю силу одного. Поэтому более подходящее название для этого осциллятора могло бы быть "Индекс внутренней силы".
    Осциллятор RSI вычисляется по формуле:
     

     
    где
    U - среднее значение закрывшихся выше предыдущих цен за определенный период.
    D - среднее значение закрывшихся ниже предыдущих цен за определенный период.
    При построении графика требуется указать этот период расчета.
    Пример окна графика с индикатором RSI по последней цене инструмента с периодом = 14.
    Чтобы построить кривую индекса относительной силы
    1. Постройте для выбранного инструмента график, как описано в разделе "Построение графиков".
    2. Щелкните правой кнопкой мыши область графика и выберите команду Индикаторы
    3. В появившемся диалоговом окне Настройки, вкладка Индикаторы в списке доступных индикаторов выделите нужный (например, RSI) и нажмите кнопку Добавить.
    4. Выберите из списка инструмент, по данным которого должен быть построен индикатор, область и ось для отображения. В нашем примере имеет смысл выбрать новую область (RSI(EESR)) и ось (RSI), чтобы индикатор RSI отобразился в новой области и его значения (от 0 до 100) отображались на отдельной оси.
    5. Укажите параметры индикатора, например, Цена=Закрытие, Период=14
    6. Измените (при необходимости) цвет и стиль линии индикатора
    7. Нажмите кнопку Применить

    Другие индикаторы
    В текущей версии программы Альфа-Директ реализованы следующие индикаторы технического анализа:
    • Горизонтальная линия
    • %R - процентный диапазон Уильямса (Williams' Percent Range (%R))
    • Acc/Swing Index - Кумулятивный индекс колебаний (Accumulation Swing Index)
    • Accumulation/Distribution - накопление/распределение
    • ADX - индикатор "системы направленного движения" (Directional Movement System) Уэллса Уайлдера (J. Welles Wilder)
    • Bollinger Bands - полосы Боллинджера
    • CCI - индекс товарного канала (Commodity Channel Index)
    • DI- - индикатор "системы направленного движения" (Directional Movement System) Уэллса Уайлдера (J. Welles Wilder)
    • DI+ - индикатор "системы направленного движения" (Directional Movement System) Уэллса Уайлдера (J. Welles Wilder)
    • MACD - схождение/расхождение скользящих средних (Moving Average Convergence/Divergence)
    • Momentum - индикатор темпа - измеряет величину изменения цены бумаги за определенный период
    • Money Flow Index - индекс денежных потоков
    • Moving Average - простая скользящая средняя (Simple Moving Average)
    • Moving Average (Exp) - экспоненциальная скользящая средняя (Exponential Moving Average)
    • Moving Average (Weight) - взвешенная скользящая средняя (Weighted Moving Average)
    • On Balance Volume - балансовый объем - динамический индикатор, соотносящий объем торгов и изменение цены
    • Parabolic - параболическая система времени/цены (Parabolic Time/Price System)
    • Price ROC - скорость изменения цены (Price Rate-Of-Change) - разность между текущей ценой и ценой n периодов назад.
    • RSI - индекс относительной силы (Relative Strength Index)
    • Stochastic Oscillator - стохастический осциллятор - сопоставляет текущую цену с диапазоном цен за выбранный период
    • Volatility - индикатор волатильности - определяет волатильность на основе ширины диапазона между максимумом и минимумом
    • Volume ROC - скорость изменения объема (Volume Rate-Of-Change) - разность между текущим объемом и объемом n периодов назад.

    Экспорт данных в программу MetaStock
    Внимание! Экспорт данных из программы Альфа-Директ может производиться только в программу MetaStock Professional версии 7.0 (или более поздней), содержащую модули DataServer и FileServer.
     
    Программа Альфа-Директ позволяет в режиме реального времени экспортировать получаемые биржевые данные в формат MetaStock, выступая при этом в качестве поставщика данных (DataVendor) в формате Signal Broadcast.
    Для того чтобы настроить вывод данных в MetaStock Professional из системы Альфа-Директ, при установке Metastock в диалоге "Select Real-Time Vendor" необходимо указать опцию "Signal (Broadcast version)":
    Сделайте поиск по локальным дискам файла winros.exe. Все файлы winros.exe, кроме одного, находящегося в папке АД, следует удалить. Для успешной организации экспорта данных из АД в Metastock на компьютере должен быть только один файл winros.exe, и находиться он должен в папке АД и это должен быть именно тот файл, который поставляется в составе дистрибутива АД (если в указанной папке нет такого файла, следует загрузить его в эту папку с нашего сервера по ссылке www.alfadirect.ru/kit/winros.exe).
    1. Создайте на жестком диске папку для экспорта, например, C:\MetaStock Data
    2. Запустите Metastock, по запросу укажите путь к файлу winros.exe (это папка, в которую была установлена система Альфа-Директ, по умолчанию C:\Program Files\Alfa-Direct, запрос происходит только при первом запуске Metastock). При этом автоматически запустятся приложения winros.exe, Metastock File Server и Equis Data Server
    3. Запустите терминал Альфа-Директ.
    4. В окне Сервис\Экспорт данных проверьте и при необходимости исправьте путь для экспорта исторических данных в Metastock - в нашем примере это C:\MetaStock Data\, после любых изменений нажмите кнопку Применить. Примечание: При осуществлении экспорта в Omega TradeStation значение данного поля игнорируется.
    5. Если в окне Сервис\Экспорт данных указано текущее состояние экспорта: Остановлен, нажмите кнопку Включить
    6. В Metastock создайте новый источник данных для получения от Альфа-Директ исторических и текущих данных по соответствующей ценной бумаге. Для этого в Metastock выберите пункт меню 'File->New->Security...'. В появившемся диалоге создания источника данных заполните следующие поля:
      • в поле 'Folder' укажите путь к той же самой папке, которая ранее была указана в окне Сервис\Экспорт данных в терминале Альфа-Директ (в нашем примере это C:\MetaStock Data\)
      • в поля 'Name' введите произвольное имя создаваемого источника данных, например 'EESR_5min'.
      • в поля 'Symbol' введите точное обозначение инструмента в Альфа-Директ (тикер), например EESR.
      Важно: Значение поля 'Symbol' в точности должно соответствовать обозначению инструмента в системе Альфа-Директ. Посмотреть обозначение нужного инструмента можно в окне Альфа-Директ Финансовые инструменты (меню Информация\Справочники\Инструменты).
      • в поле 'Periodicity' выберите, значение 'Intraday' или 'Daily'
      • в поле выбора 'Units' выберите значение 'Decimal'.
      • в поле 'Interval' введите значение интервала для хранения данных, например, 5 min
      • в поле 'Start Time' и 'End Time' введите значения 00:00 и 00:00
    7. Нажмите кнопку Ok и на все последующие за этим вопросы отвечайте 'Yes'. Если Вы всё сделали правильно, источник данных будет создан, сразу же начнут загружаться текущие данные (по мере их поступления), а через некоторое время (1-2 минуты) загрузится история котировок для данного инструмента.
    Примечание: в настоящее время действует ограничение на максимальную глубину загрузки истории за один раз для графиков в зависимости от периодичности - для 1-минутных графиков это неделя, для 5-минутных - месяц, для 15-минутных - 3 месяца, 30-минут - полгода, 1-час - год, daily- и выше графики - история загружается без ограничений. Например, если нужно загрузить 1-минутную историю за 2 недели - нужно сделать 2 запроса, по 1 неделе каждый.
    Совет: В окне Сервис\Экспорт данных включите опцию    включить экспорт в Metastock/OmegaTS при подключении, чтобы при каждом подключении к серверу Альфа-Директ автоматически запускался экспорт данных в указанные системы технического анализа.
    В окне Сервис\Экспорт данных включите опцию    выгрузить модуль загрузки данных при выключении экспорта, чтобы при выключении экспорта модуль экспорта данных winros.exe автоматически выгружался из памяти компьютера

    Экспорт данных в программу Omega Trade Station
    Установка и настройка Omega ProSuite2000.
    Для того чтобы настроить вывод данных в Omega ProSuite2000 из системы Альфа-Директ, необходимо установить этот продукт соответствующим образом. Во время установки нужно правильно задать следующие опции:
    1. в диалоге "3rd Party Data Vendor Software" установить опцию "DBC - Supports: Signal Broadcast, eSignal Online, and InSite Online."
    1. В диалоге "DBC Data Feed Selection" установить опцию "Signal Broadcast".
    1. В диалоге "3rd Party Data Vendor Software Installation" отказаться от установки - выбрать вариант "No"
    1. После установки Omega ProSuite2000 перезагрузите компьютер.
    2. Во время первого запуска программы Omega Research ProSuite она попросит вас настроить Global Server. Выберите опцию "Launch the GlobalServer Setup Wizard".
    1. В диалоге "GlobalServer Setup Wizard - Data Collection Method" установите опцию "Real-Time/Delayed (You will be collecting...)".
    1. В диалоге "GlobalServer Setup Wizard - Select Datafeed" выберите опцию "DBC Online SubServer".
    1. диалоге "GlobalServer Setup Wizard - HISTORYBANK.COM ..." выберите опцию "No".
    1. Во время первого запуска программы Global Server в диалоге выбора режима работы выберите режим "Start Online".
    1. Закройте Global Server и перезагрузите компьютер еще раз.
    2. После перезагрузки запустите файл winros.exe из папки alfa-direct (если в указанной папке нет такого файла, следует загрузить его туда с нашего сервера по ссылке www.alfadirect.ru/kit/winros.exe). В дальнейшем файл winros.exe будет запускаться автоматически при запуске Omega TS и Global Server
    3. Приступите к организации экспорта данных как описано ниже.
    Организация экспорта данных.
    1. Запустите приложение Omega Research ProSuite (при этом автоматически запустятся приложения winros.exe и Global Server)
    2. Запустите систему Альфа-Директ и подключитесь к серверу в обычном порядке.
    3. Если в Альфа-Директ в окне Сервис\Экспорт данных указано текущее состояние экспорта: Остановлен, нажмите кнопку Включить
    4. В программе "Global Server" для каждого инструмента необходимо создать источник данных для обмена информацией между программами Omega ProSuite и Альфа-Директ. Для этого в контекстном меню Global Server выберите пункт 'Insert->Symbol'. В появившемся диалоге нажмите кнопку "Add New". После этого появится диалог создания источника данных. Заполните в нем следующие поля:
      • в поле выбора 'Data Source' выберите значение 'DBC Online'.
      • в поле выбора 'Category' выберите значение 'Stock'.
      • в поле 'Symbol' введите имя создаваемого источника данных, например 'EESR'.
      • в поле выбора 'Exchange' выберите значение 'CFOREX - Crossmar Foreign Exchange'.
    Важно. Значение поля 'Symbol' в точности должно соответствовать обозначению инструмента в системе Альфа-Директ. Посмотреть обозначение нужного инструмента можно в окне Альфа-Директ Финансовые инструменты (меню Информация\Справочники\Инструменты).
    После этого нажмите кнопку "Ok". После этого появится диалог настройки источника данных "Add stock".
    1. На вкладке "Stock" в полях "Trading Name", "Description" и "Symbol Root" укажите то же символьное обозначение инструмента, которое Вы указали в поле 'Symbol' при создании источника данных в предыдущем диалоге.
    1. На вкладке "Sessions" заполните расписание торговой сессии. В поле выбора 'Display Session Times in:' выберите значение 'Exchange Traded Time'. Расписание торговой сессии необходимо заполнить следующим образом:
    После выполнения настройки нажмите кнопку Ok и на все последующие за этим вопросы отвечайте 'Ok'. Если Вы всё сделали правильно, источник данных будет создан.
     
    После этого выберите созданную бумагу в списке бумаг в GlobalServer, нажмите на правую кнопку мыши, выберите пункт меню Connect Symbol.
    Если перед этим вы сделали все правильно состояние в колонке "Real-Time Status" изменится на "Connected". Если этого не произошло, значит на предыдущих шагах что-то было сделано неправильно.
     
    Приступить к работе с программой Omega Trade Station.
    Примечание: в настоящее время действует ограничение на максимальную глубину загрузки истории за один раз для графиков в зависимости от периодичности - для 1-минутных графиков это неделя, для 5-минутных - месяц, для 15-минутных - 3 месяца, 30-минут - полгода, 1-час - год, daily- и выше графики - история загружается без ограничений. Например, если нужно загрузить 1-минутную историю за 2 недели - нужно сделать 2 запроса, по 1 неделе каждый.
    Совет: В окне Сервис\Экспорт данных включите опцию    включить экспорт в Metastock/OmegaTS при подключении, чтобы при каждом подключении к серверу Альфа-Директ автоматически запускался экспорт данных в указанные системы технического анализа.
    В окне Сервис\Экспорт данных включите опцию    выгрузить модуль загрузки данных при выключении экспорта, чтобы при выключении экспорта модуль экспорта данных winros.exe автоматически выгружался из памяти компьютера

    Принудительный запрос данных с сервера
    Как правило, пропущенные данные по финансовому инструменту заполняются автоматически при очередном запуске экспорта в Metastock или OmegaTS. Но иногда может потребоваться обновление имеющихся или заполнение пропущенных данных с сервера за определенный период. Для принудительного запроса исторических данных по инструменту за определенный период:
    1. Запустите MetaStock или OmegaTS (экспорт в обе программы одновременно невозможен);
    2. Запустите систему Альфа-Директ и подключитесь к серверу в обычном порядке;
    3. В Альфа-Директ откройте окно Сервис\Экспорт данных
    4. В случае экспорта в MetaStock проверьте и при необходимости исправьте путь к файлам БД Metastock, после любых изменений нажмите кнопку Применить.
    5. Проверьте текущее состояние экспорта - если указано "Остановлен", нажмите кнопку Включить;
    6. В списке доступных инструментов должны появиться все инструменты, созданные в Metastock с соответствующей периодичностью, а в случае работы с OmegaTS для каждого инструмента в списке будет две строки - 1-мин и daily.
    7. выберите инструменты для запроса данных с сервера из доступных с учетом периодичности
    8. Укажите период, за который следует обновить данные
    9. Нажмите кнопку Загрузить.
    10. через некоторое время (1-2 минуты, зависит от количества запрошенных инструментов, периода, качества связи) запрошенные данные появятся в MetaStock или OmegaTS.